Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

Impres Charger

The General forum is where users can discuss any topic regarding Motorola communications equipment - hardware, software, etc. There are also several focused forums on this board, so please take the time to ensure that your questions doesn't fall into one of those categories before posting here!

Moderator: Queue Moderator

Jim1348
Posts: 538
Joined: Sun Aug 15, 2004 7:52 am

Impres Charger

Postby Jim1348 » Mon Apr 03, 2017 6:03 pm

We have several Motorola Impress gang chargers at work. I was informed today that one of the pockets is not working. Is the Q tip and isopropyl alcohol cleaning method still the firs thing to try? Also, if I am cleaning one, I suspect that I should clean all?

If that doesn't work out, what is the next step to take? I know that there have been similar post in the past, but I am just trying to make sure that nothing has changed since those older posts.

Return to “General Motorola Solutions & Legacy Radio Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests