Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

Motorola Micom 2EF HF radio

The General forum is where users can discuss any topic regarding Motorola communications equipment - hardware, software, etc. There are also several focused forums on this board, so please take the time to ensure that your questions doesn't fall into one of those categories before posting here!

Moderator: Queue Moderator

g8tzl2004
Posts: 1082
Joined: Wed Sep 08, 2004 10:13 am

Motorola Micom 2EF HF radio

Postby g8tzl2004 » Sun Aug 13, 2017 11:03 am

I have recently acquired a Motorola 2EF HF radio with the desktop head.

The radio does not power up. I have checked the power lead and fuses and all is OK. I think the problem is a disconnected "flat blade" black wire link between the head and main body..but I'm not going to connect it up until I have done some research.

The 2EF head does not fit tight onto the radio body. I think its missing a back assembly which locks the head in place on the main body. Currently the head is taped to the main body. The head is connected to the body by a long flex ribbon cable which is folded up inside the head.

Does anybody have a Micom 2EF version and can confirm the the head is connected to the main body by a black wire link using an inline flat blade connector, as well as the ribbon cable?

Thanks

Return to “General Motorola Solutions & Legacy Radio Discussion”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests