Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

HT 1250 mic issue

This forum is for discussions regarding all aspects of Motorola radio programming, including hardware, computers, installation and use of RSS/CPS, firmware upgrades, and troubleshooting. There are subforums for discussions of codeplugs, and also for software/firmware release notes and issues.

Moderator: Queue Moderator

Fire3821
New User
Posts: 2
Joined: Sat Apr 11, 2015 12:50 am

HT 1250 mic issue

Postby Fire3821 » Sat Apr 11, 2015 1:01 am

I've replaced the mic on my HT1250 twice now, I've cleaned the connectors. The mics don't always work. I can key it up and work fine and 2 minutes later I try keying it up and it won't work. Any ideas?

xxx2fan
Posts: 64
Joined: Mon Oct 31, 2005 4:42 pm
What radios do you own?: HT750 Ht1250 CDM1250 CDM1550

Re: HT 1250 mic issue

Postby xxx2fan » Wed Dec 28, 2016 3:51 pm

Take the radio apart and try to reinstall the ribbon traces. Have found this on some of Fire Dept. radios. Most likely dropped or hard service.


Return to “Radio Programming”

Who is online

Users browsing this forum: No registered users and 1 guest