Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

Xts5000 charging issue with RLN4884B

This forum is dedicated to discussions pertaining specifically to the Motorola ASTRO line of radios (those that use VSELP/IMBE/AMBE), including using digital modulation, digital programming, FlashPort upgrades, etc. If you have general questions please use the General or Programming forums.

Moderator: Queue Moderator

Garda162
New User
Posts: 1
Joined: Tue Jan 21, 2014 5:48 pm

Xts5000 charging issue with RLN4884B

Postby Garda162 » Tue Jan 28, 2014 4:06 pm

I'm having an issue charging my xts5000. I'm using NNTN4435b batteries.
The radio and all the batteries charge fine on the normal impress charger. If I use it with a RLN4884b travel charger, although it will say charging for some time, will not charge.
I assumed it was my charger so I went ahead and bought another travel charger and I got the same outcome.

Is anyone aware of any issues while using this combination? Anyone have a solution?

Return to “Legacy Batboard Motorola ASTRO (VSELP/IMBE/AMBE) Equipment Forum”

Who is online

Users browsing this forum: No registered users and 1 guest