Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

2012 Dodge 1500 Hemi Coil Whine

This forum is dedicated to helping people with questions about installing radio equipment in vehicles. This can include antenna installs, electrical wiring questions/problems, and mounting systems. Pictures of installs are welcome.

Note: Discussions regarding lighting, sirens, and other equipment now has its own forum in the 'off-topic' section below.

Moderator: Queue Moderator

cms1126
Posts: 45
Joined: Tue Sep 01, 2009 10:51 pm

2012 Dodge 1500 Hemi Coil Whine

Postby cms1126 » Thu Oct 24, 2013 8:00 am

Okay I am completely perplexed. We have two 2012 Dodge Ram 1500 Hemi's that have a horrible whine coming through both TK790's installed in it. Both radios are wired directly to the battery, have line filters installed, and all vehicle grounds have been checked and reinforced. Here is the kicker...if I unplug the passenger side coils, the noise goes away. Dodge claims there is nothing they will do about it. Anyone have any suggestions? its to the point where you cant understand anything on the radios. No Issues with the stock stereo.

cms1126
Posts: 45
Joined: Tue Sep 01, 2009 10:51 pm

Re: 2012 Dodge 1500 Hemi Coil Whine

Postby cms1126 » Thu Oct 24, 2013 8:26 am

Upon further research, I found this thread viewtopic.php?f=8&t=72881&hilit=whine sounds like the identical problem to me. however no one has a fix for it.

tvsjr
Posts: 4113
Joined: Fri Nov 28, 2003 9:46 am

Re: 2012 Dodge 1500 Hemi Coil Whine

Postby tvsjr » Thu Oct 24, 2013 8:41 pm

Welcome to the HEMI. From the description, sounds like one of the coils on that bank is bad... you'll have to go through them one by one to identify, then replace it.

Alternatively, unbolt those radios and drive a Ford product underneath them (or anything without a HEMI).

User avatar
MSS-Dave
Posts: 766
Joined: Mon Jun 30, 2003 6:02 pm
What radios do you own?: XTL5K, NX300, PD782, Spark Gap

Re: 2012 Dodge 1500 Hemi Coil Whine

Postby MSS-Dave » Fri Oct 25, 2013 3:38 am

Alternatively, unbolt those radios and drive a Ford product underneath them (or anything without a HEMI).


:lol:

Priceless! Thanks for the laugh. Maybe being "Imported from Detroit" gets you cheese with that fine whine....

Dave

cms1126
Posts: 45
Joined: Tue Sep 01, 2009 10:51 pm

Re: 2012 Dodge 1500 Hemi Coil Whine

Postby cms1126 » Sun Nov 03, 2013 10:57 am

The issue is pretty low on my to do list right now. But the laugh was appreciated! I did find the coil pack that was the culprit...just gotta see if they will order a replacement.

User avatar
nukedude
Posts: 59
Joined: Fri Apr 16, 2010 9:40 am
What radios do you own?: Many Motorola's

Re: 2012 Dodge 1500 Hemi Coil Whine

Postby nukedude » Wed Jun 18, 2014 6:55 am

This has also been known to happen on: Pontiacs, Impalas and other vehicles with high voltage coil packs as well. I once had to troubleshoot a fleet of Impalas that all had this problem, it took some convincing to the maintenance crew that this was not a radio problem. They had to see it for themselves. (Luckily, I drive a Pontiac that used the same coil packs and showed them myself.)


Return to “Vehicle Radio Installs”

Who is online

Users browsing this forum: No registered users and 1 guest