Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

Motorola SM 120 channel buttons

The General forum is where users can discuss any topic regarding Motorola communications equipment - hardware, software, etc. There are also several focused forums on this board, so please take the time to ensure that your questions doesn't fall into one of those categories before posting here!

Moderator: Queue Moderator

The_Kid
New User
Posts: 10
Joined: Thu Aug 02, 2012 4:48 pm
What radios do you own?: MT1000, HT1000

Motorola SM 120 channel buttons

Postby The_Kid » Fri Oct 19, 2012 8:20 am

Hi, I have a SM120 and the channel selector buttons and scan buttons are hard to press or sometimes they dont even work. Is there anyway to fix this problem?

Thanks for any help or info,
Marc

KG4INW
Posts: 269
Joined: Thu May 22, 2008 3:31 pm
What radios do you own?: Not enough apparently!

Re: Motorola SM 120 channel buttons

Postby KG4INW » Fri Oct 19, 2012 9:35 am

You might be able to carefully disassemble the head and clean the underside of the buttons, not using any water, of course. There's probably a buildup of crud under there if the radios well used. Other than that, perhaps a new head would be needed.

Al
Posts: 1045
Joined: Tue Sep 04, 2001 4:00 pm

Re: Motorola SM 120 channel buttons

Postby Al » Fri Oct 19, 2012 8:29 pm

If the back of the buttons(where they contact the small PCB) has lost its conductive coating through age and use you can repair the coating by applying new coating from a repair kit available from at least two suppliers of circuit board repair kits.

The_Kid
New User
Posts: 10
Joined: Thu Aug 02, 2012 4:48 pm
What radios do you own?: MT1000, HT1000

Re: Motorola SM 120 channel buttons

Postby The_Kid » Sun Oct 21, 2012 6:06 pm

Thank you for the replies and ideas. I will try cleaning the contacts first and if that doesn't work I will try some of that conductive coating.


Return to “General Motorola Solutions & Legacy Radio Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests