Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

CPS Software and Windows 7 64-bit

This forum is for discussions regarding all aspects of Motorola radio programming, including hardware, computers, installation and use of RSS/CPS, firmware upgrades, and troubleshooting. There are subforums for discussions of codeplugs, and also for software/firmware release notes and issues.

Moderator: Queue Moderator

PFD R-11
New User
Posts: 1
Joined: Tue Sep 02, 2014 6:04 am

CPS Software and Windows 7 64-bit

Postby PFD R-11 » Tue Sep 02, 2014 6:10 am

Hi everyone,

This question has been asked multiple times on this forum (and others), but I have not found an answer that works for me, so I’m going to ask it a different way.

I recently bought a new computer with Windows 7 64-bit, and I downloaded the latest versions of the CPS software (06.12.09) and Minitor V software (1.7.2). I have a RIB, a RIB to serial cable, and a RIB to HT1250 cable, all which came directly from Motorola. It’s all connected to the computer via a USB-to-serial adapter.

Long story short, I can program pagers just fine, but no luck with HT1250 radios. I’m getting the “Cannot connect to radio, ensure RIB and radio are powered on, and that all connections are OK” error message, which is momentarily preceded by a “Program not responding” message in the program title bar. I have uninstalled and re-installed the USB to serial adapter drivers, uninstalled and re-installed the CPS software, ensured I was using the correct COM port within the CPS software, tried different serial port speeds in Device Manager, made sure all the connections to the computer/RIB/radio were OK, changed the battery in the RIB, and made sure that the RIB and radio were both powered on. I know the problem is not with the USB to serial adapter, because I can program pagers fine. I know the problem is not with the RIB or cables, because I can program radios with my old (Windows XP) computer. I have the latest version of the software, which is supposed to address the Windows 7 and 64-bit issues. I’m out of ideas. If anyone thinks they can help, please share your thoughts! Many thanks.

Jason

Al
Posts: 1045
Joined: Tue Sep 04, 2001 4:00 pm

Re: CPS Software and Windows 7 64-bit

Postby Al » Sun Sep 07, 2014 4:09 am

Jason, I'm using a system very similar to what you have with no trouble programming the HT Waris series. What I've seen in the past is that some USB to serial port adapters don't emulate a serial port very well. I would suggest trying an adapter based on the Prolific Technology PL-2303 series of chips and using the latest(I believe it's 1.9.0) Prolific driver available on their website. If you check the Prolific website, you'll see that they warn of knockoff(counterfeit) adapters being sold as Prolific-based stuff that don't emulate a serial port well. In addition, their current driver package contains a standalone program that will identify a true Prolific chipset adapter and tell you which version of their chip that your adapter is using.

tgo
Posts: 70
Joined: Sun Jan 05, 2003 8:02 am

Re: CPS Software and Windows 7 64-bit

Postby tgo » Sat Oct 18, 2014 6:56 am

Al and PFD R-11, I would like to know what hardware (cables, adapters, gender changers) you may be using to program with CPS. I have a "plugable" brand USB adapter which terminates in a DB9 male connector, and Prolific driver installed. The input on the RIB is a DB15 male. It would be great to use my new Lenovo laptop for CPS rather than keeping my old Dells working for this purpose.

tgo
Posts: 70
Joined: Sun Jan 05, 2003 8:02 am

Re: CPS Software and Windows 7 64-bit

Postby tgo » Sat Oct 18, 2014 10:22 am

Figured out the cabling, using original Motorola PC-RIB cable and Plugable USB adapter, set adapter as COM2 in Device Manager, selected COM2 in Astro Spectra CPS, still no communication with radio. Must be a port settingneedss changing?

Fratolicious
New User
Posts: 6
Joined: Fri Sep 26, 2014 6:39 am

Re: CPS Software and Windows 7 64-bit

Postby Fratolicious » Wed Oct 22, 2014 6:03 am

This may be silly but have you physically looked at the accessory connector of the radio? I have had those get dirty and could not make a good connection causing error to read. This has been very common on radios not using the dust cover when a microphone is not in use. Just a thought. The computer not responding is something not common in my experience.

Good Luck.

~Frato

tztop10
Posts: 34
Joined: Mon Sep 29, 2014 2:08 am
What radios do you own?: HT1250 EX600XLS CDM1250 CP200

Re: CPS Software and Windows 7 64-bit

Postby tztop10 » Mon Oct 27, 2014 2:57 am

I would check your com-port settings to see what port you are using, you can also switch the com port if needed, this sounds dumb, but have you restarted you machine since installing CPS, this would cause the software not to be able to read the radio, a simple reboot would fix that. also try using a different port.


Return to “Radio Programming”

Who is online

Users browsing this forum: No registered users and 1 guest