Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

XTS3000 CPS Communication Failed

This forum is for discussions regarding all aspects of Motorola radio programming, including hardware, computers, installation and use of RSS/CPS, firmware upgrades, and troubleshooting. There are subforums for discussions of codeplugs, and also for software/firmware release notes and issues.

Moderator: Queue Moderator

New User
Posts: 1
Joined: Sat Jul 23, 2016 12:18 pm

XTS3000 CPS Communication Failed

Postby RadioDitch » Sat Jul 23, 2016 12:22 pm

Hey gents, I need some help here.

I purchased a new laptop, running Windows 10, and installed the correct (legally possessed) Sabre/XTS3000 CPS. However I keep getting "Communication With Radio Failed". Kinda stumped since...

-The serial to USB adapter I just bought has the proper drivers installed, and the computer recognized it correctly.
-This ribless cable has worked before without issue on other computers.
-Connections are tight and have good contact.
-Astro25 Portable CPS recognized and attempted to read the radio (tried it as a litmus test for the connection), so the correct Sabre/XTS3000 CPS should too.
-Correct port is selected.
-Running CPS as administrator.

I'm guessing I should try a different Serial to USB adapter? Any help?

User avatar
Victor Xray
Posts: 844
Joined: Mon Dec 17, 2001 4:00 pm

Re: XTS3000 CPS Communication Failed

Postby Victor Xray » Sat Jul 23, 2016 2:36 pm

Windows 10 is Not supported for Astro CPS. If you absolutely want to use it regardless of the consequences, then you have to use the 32 bit version, not 64 bit.

New User
Posts: 10
Joined: Thu Nov 20, 2014 10:48 am

Re: XTS3000 CPS Communication Failed

Postby Pyrojim » Mon Aug 07, 2017 6:52 am

I have the same problem on Windows 10. I've tried setting the compatibility to XP and or Vista with no luck. Any other suggestions?

New User
Posts: 13
Joined: Sat Feb 18, 2017 5:54 pm
What radios do you own?: APX8KXE, XTS5K, XTL5K

Re: XTS3000 CPS Communication Failed

Postby ME801 » Mon Sep 11, 2017 2:54 pm

The only computer's I've been able to get to work with Astro CPS is true 32 bit processors on XP and Win 7, and have a COM port. I have not had any luck with the USB adapters. Other's may have a different experience, but that's been my luck.

New User
Posts: 5
Joined: Sat Jul 09, 2016 6:59 am

Re: XTS3000 CPS Communication Failed

Postby pallen444 » Fri Sep 29, 2017 4:45 pm

i use windows 10 to program all my xts3000 sometimes i have to open device manger and update drivers works fine 32 bit.

Return to “Radio Programming”

Who is online

Users browsing this forum: No registered users and 1 guest