MTS 2000 programming block error

This forum is for discussions regarding all aspects of Motorola radio programming, including hardware, computers, installation and use of RSS/CPS, firmware upgrades, and troubleshooting. There are subforums for discussions of codeplugs, and also for software/firmware release notes and issues.

Moderator: Queue Moderator

Post Reply
New User
Posts: 1
Joined: Sat Feb 03, 2018 9:48 am

MTS 2000 programming block error

Post by molay »

Greetings from the overseas MTS newbie!

I have been given a MTS2000 Flashport recently and also bought an aftermarket ribless programming cable for it. I launched RVN4776_v2.03.00_MTS2000 CPS on my laptop and tried to read the radio (i've never done it with this radio before btw). "1CSQ" appeared on the display of the radio and after a while and some radio reboot CPS provided me the following error message: "No user function provided to convert block type to block ID for block with type 255. Unpack failed."

After checking various post and forums I tried to read radio from a pure MSDOS machine with MTSXLAB, that which gives me a non-recoverable error "[Block Type Error]". However the function Read / Write Radio with No Pack / UnPack works correctly, although it does not allow me to change anything on the radio , at least the interface seems to works properly.

Why can't I read/write codeplug to my MTS? The radio appears to be in good condition. What's the problem and what can I do? Please help me!

Model #: H01KDD9PW1BN
New User
Posts: 1
Joined: Sun Feb 18, 2018 8:46 pm

Re: MTS 2000 programming block error

Post by radicalbill »

Did you ever find the problem with reading the radio ?

I am about to try to read mine and I know there is something about the codeplug and firmware needing to be written at the same time, a security measure by M

Not sure if it has to do with needing a newer version of CPS

I read that 2.03.00 is not the last, but 5.18.00 was, and no one seems to have that version, or 5.17.00

How do you read and save the radio without unpacking ?

Any help would be great


User avatar
Posts: 7339
Joined: Sun Sep 09, 2001 4:00 pm

Re: MTS 2000 programming block error

Post by wavetar »

Hi Bill,

6.08.00 was the last DOS based version of the MTS RSS (Radio Service Software). 2.03.00 was the last Windows based version of the CPS (Customer Programming Software). If the radio has really old firmware in it, like 5.xx or lower, the Windows CPS will not work with it, as it was developed afterwards, and you'll need to use the DOS RSS. You may not need the latest version of DOS RSS, it depends on what the radio was last written with. I believe 6.04.00 was the latest version for several years, and many people did not upgrade to later revisions as their subscriptions had run out. So, it may work for you.

There is no 'codeplug & firmware needing to be written at the same time' requirement.
No trees were harmed in the posting of this message...however an extraordinarily large number of electrons were horribly inconvenienced.

Welcome to the /\/\achine.
Posts: 47
Joined: Tue Feb 15, 2005 10:28 am

Re: MTS 2000 programming block error

Post by kd5ual »

also remember that using LAB on MTS2000 may brick your radio!!!
do a search for MTS2000 TOOLPROOF
Posts: 1854
Joined: Tue Jan 13, 2004 7:03 am

Re: MTS 2000 programming block error

Post by motorola_otaku »

MTSX radios (Jedi series portables and MCS2000 mobiles) are famous for not playing well with aftermarket RIB hardware. At the bare minimum you need a good clone of a RLN4008 RIB (I think Kawa copies the schematic but subs SMT components for leaded) and a physical serial connection to the computer. The errors you're posting are consistent with corrupted data being read from the radio.

It's also possible that the codeplug is corrupted internally, in which case you have a nice paperweight (not economical to torubleshoot.)
Post Reply

Return to “Radio Programming”