Page 1 of 1

XPR6550 Loud Uncontrolled Squeal

Posted: Fri Jan 06, 2017 8:40 am
by gatekeep
I have a few NOS dealer trade in XPR6550's on my bench that intermittently will (without warning) begin uncontrollable loud squealing from the speaker after receiving analog traffic.

Anyone run into this sort of issue? Some quick research seems to indicate this could be the result of a faulty volume pot or bad solder joints at the volume pot.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Sat Jan 21, 2017 4:43 am
by TreyH
Are they on firmware 1.12.17? There's talk of a bug in that firmware version causing that issue. I've experienced it on some of mine but that's been on a digital channel.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Sat Jan 21, 2017 6:58 am
by W3AXL
The "squeal of death" is a known issue in older firmware and the solution is to upgrade to the latest version. A decent amount of our radios had the problem and Motorola originally didn't know what was going on. Eventually they just told us that a firmware upgrade should fix the problem, which it seems to have done.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Thu Jan 26, 2017 8:16 am
by gatekeep
W3AXL wrote:The "squeal of death" is a known issue in older firmware and the solution is to upgrade to the latest version. A decent amount of our radios had the problem and Motorola originally didn't know what was going on. Eventually they just told us that a firmware upgrade should fix the problem, which it seems to have done.


What firmware revision? I have the radios loaded with R01.12.17 (exactly the version TreyH says it occurs on).

Side note: "Squeal of death" -- I love it.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Sun Jan 29, 2017 4:55 pm
by Gtaman
Mine does it. It's on 1.12.17. Not often but it has happened.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Sun Jan 29, 2017 7:17 pm
by TreyH
I've been holding off upgrading our fleet for a while now, hoping to hear more about the issue. I may go ahead and update one shift and see how it goes. Firmware 1.12.13 doesn't have that problem but the only way to downgrade is if you have the Depot software. I'd like to go to 1.12.17 due to the AGC/Audio fixes that were implemented. Gen 1 radios below fw 1.12.17 using AGC don't seem to play well with Gen 2 radios.

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Mon Jan 30, 2017 6:28 am
by gatekeep
TreyH wrote:I've been holding off upgrading our fleet for a while now, hoping to hear more about the issue. I may go ahead and update one shift and see how it goes. Firmware 1.12.13 doesn't have that problem but the only way to downgrade is if you have the Depot software. I'd like to go to 1.12.17 due to the AGC/Audio fixes that were implemented. Gen 1 radios below fw 1.12.17 using AGC don't seem to play well with Gen 2 radios.


Agreed. There is a DMR system I operate a few units on and I've found that the Gen 1 radios below the latest R01.12.17 firmware have serious audio quality issues (related to AGC and DSP as you stated) when operating with Gen 2 radios. I updated most of the radios to R01.12.17 and have gotten a few reports from the field that the squeal of death was occurring. So far my only suggestion to subscribers has been to pull the battery to immediately stop squeal or power off the radio normally (which also does the trick but takes longer).

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Mon Sep 24, 2018 11:26 am
by K9LPK
Bryan,

I am still seeing this issue with latest firmware with XPR6580 also xpr7580 900 MHz w/Connect Plus option.
we have 900+ subscribers on our infrastructure. Still waiting to hear from Motorola Solutions on this topic.

We may not all walk on water, but when we do! We make sure the Ice is Thick!

Re: XPR6550 Loud Uncontrolled Squeal

Posted: Tue Sep 25, 2018 11:51 am
by com501
There is a fix for the 'squal of death' for the XPR6xxx series. Ask Motorola to send you firmware version S01.17.08 update package.