SL7550 Screen

Moderator: Queue Moderator

Post Reply
User avatar
tdats
Posts: 172
Joined: Tue Jun 10, 2008 8:23 am
What radios do you own?: Mostly Motorola

SL7550 Screen

Post by tdats »

I have a SL7550 (not an E version) with a broken screen.

I ordered a replacement screen from Wiscom. After a long backorder from Motorola, including a part# change, I finally have the screen. Putting it in the radio, I get nothing at all on the screen. It just stays black, no flickers, no nothing. Putting the old screen back in, it works as well as it did before. (Lights up, lines on the screen, etc)

The screens do look different on the back.

Anyone know if mother M had changed some hardware or something? If so, anyone know where I can get my hands on a non e series radio screen?

Trying to rule out something like that before I pursue it being a bad replacement screen.

Thanks!

Image
User avatar
escomm
Queue Moderator
Posts: 5168
Joined: Fri Mar 24, 2006 8:24 pm

Re: SL7550 Screen

Post by escomm »

Sounds like a sales support question for your vendor. They do support their sales, right ?
com501
Posts: 1062
Joined: Fri Nov 02, 2001 4:00 pm
What radios do you own?: Over 50 - All Motorola

Re: SL7550 Screen

Post by com501 »

if you don't have access to MOL support, then yes, as stated, call the vendor. There have been several changes on those radios. The new one is the new version with the JTAG port visible.
User avatar
MotoFAN
Posts: 1040
Joined: Thu Jun 28, 2007 6:46 am
What radios do you own?: Approx. 50: Moto & Kenwood

Re: SL7550 Screen

Post by MotoFAN »

What is the FW version in radio? Upgrade it to the latest first. I remember the situation with XTS3000 where display mfg. was changed and required new driver to work. Driver is part of firmware package. I can't guarantee, it's just my expirience with another series radio.
I am biggest fan of XTS2500 and ASTRO Digital Saber.
User avatar
tdats
Posts: 172
Joined: Tue Jun 10, 2008 8:23 am
What radios do you own?: Mostly Motorola

Re: SL7550 Screen

Post by tdats »

Contacted Motorola trough MOL, gave them the radio TANAPA and model and they came back with the part# for the new screen I had received that does not work.

It actually appears that the radio would not complete it's bootup with that new screen. I could not get my computer to recognize the radio at all with the new screen in, put the old broken one back in and it would connect right up to the computer. Did verify the newest firmware on the radio as well.

Decided at this point I am done messing with it and sent it to depot. So, no good answer on what the issue is, but I am pretty sure there are multiple screen versions out there, and they do not seem to be compatible with each other. I'll have to see when the radio comes back what screen it has in it.
Post Reply

Return to “MotoTRBO Portables and Mobiles (3xxx/5xxx/7xxx/SL) 2.0 Series Subscribers”