Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

XTL5000 UHF - Dead Power Amplifier (PA)?

Moderator: Queue Moderator

User avatar
seleong
Posts: 273
Joined: Sun Sep 09, 2001 4:00 pm

XTL5000 UHF - Dead Power Amplifier (PA)?

Postby seleong » Mon Sep 30, 2019 10:52 am

Hello!

My remote mount UHF mid-power XTL5000 power amplifier seems to have died. No Tx output power measured at the mini-UHF connector. Mounted in a relatively benign environment in the trunk of my car.

Not sure what my options are for the (cost effective) repair of this radio. I do not know how difficult it is to troubleshoot and/or replace the PA module in the radio.

Appreciate any recommendations on repair / troubleshooting.

Thanks very much!

Steve

com501
Posts: 1060
Joined: Fri Nov 02, 2001 4:00 pm
What radios do you own?: Over 50 - All Motorola

Re: XTL5000 UHF - Dead Power Amplifier (PA)?

Postby com501 » Mon Sep 30, 2019 2:54 pm

IF you can get the RF module, it requires good skills to remove and replace. You will also need to adjust bias current in autotune with an Aeroflex with the current shunt.

Troubleshoot first, as the PA is sometimes the problem and sometimes the driver/pre-driver stages instead. All surface mount.

Check the stupid mini-u connector and look at the PA current before going any further. Frequent failures with mis-crimped connectors causing the receptacle to FUBAR.

User avatar
seleong
Posts: 273
Joined: Sun Sep 09, 2001 4:00 pm

Re: XTL5000 UHF - Dead Power Amplifier (PA)?

Postby seleong » Mon Sep 30, 2019 5:30 pm

Hello com501!

Many thanks for your reply! I appreciate the pointers and suggestions and will attempt the troubleshooting route for sure. I will dig out the schematics and see if I can trace the circuitry backwards to see if there is something obvious. I just can't this nice of a radio can be turned into a bookend so easily...

Thanks again!

Steve


Return to “ASTRO25 Series (XTS/XTL 1500/2500/5000) Subscribers”

Who is online

Users browsing this forum: No registered users and 1 guest