Users may not create topics, posts, or private messages containing or relating to the following material (especially pertaining to Motorola copyrighted software, unless you want Motorola to come along and shut this site down):

  • Listing for sale or trade of, or links to sites offering for sale or trade of, or giving away, Radio
    Service Software (RSS) or Customer Programming Software (CPS)
  • Profanity, pornography, defamation, or slanderous remarks directed towards any individual or entity
  • Commercial advertising (except in the Batboard Vendors forum, as approved by the Admin/Mod Staff)
  • Any other items which may be deemed as offensive

If any topics, posts, or private messages containing or relating to the aforementioned material are brought to the attention of the Admin/Mod Staff, they will be deleted.

Additional FAQ items appear here in Forum Rules. Please review them for posting guidelines and further clarification.

APX7000 error code 15/10 what is it?

The General forum is where users can discuss any topic regarding Motorola communications equipment - hardware, software, etc. There are also several focused forums on this board, so please take the time to ensure that your questions doesn't fall into one of those categories before posting here!

Moderator: Queue Moderator

KG4FOY
Posts: 156
Joined: Wed Feb 21, 2007 9:33 am

APX7000 error code 15/10 what is it?

Postby KG4FOY » Mon Apr 30, 2012 12:20 pm

I get a error code on boot, it lasts about a tenth of a second and the radio appears normal. the error code is 15/10, anyone know what it means?

KG4FOY
Posts: 156
Joined: Wed Feb 21, 2007 9:33 am

Re: APX7000 error code 15/10 what is it?

Postby KG4FOY » Tue May 01, 2012 7:58 am

ok problem solved, apparently it's a codeplug error.

Jim202
Posts: 3569
Joined: Sun Sep 09, 2001 4:00 pm

Re: APX7000 error code 15/10 what is it?

Postby Jim202 » Wed May 02, 2012 2:54 am

KG4FOY wrote:ok problem solved, apparently it's a codeplug error.



Typically in the older radios, the second number being a 10 indicates something wrong with the serial bus. The leading 15 I am not sure of. Maybe an indication that you have turned on a security setting by mistake.

I have yet to see an error code listing for the APX that goes outside the common errors that show up.

Jim

Ken.Adams
Posts: 11
Joined: Tue Apr 06, 2010 2:23 pm

Re: APX7000 error code 15/10 what is it?

Postby Ken.Adams » Tue May 08, 2012 7:54 pm

This error occurs when Radio Ergonomics Configuration -> Radio Ergonomics Wide -> External Accessory Enable is checked, but no external accessory is connected. The CPS does not explain this very well, but "External Accessory" does not include remote speaker mics or similar accessories. I believe this checkbox basically toggles between SB9600 and XCMP on the accessory connector.

Having this checkbox checked can interfere with non-XCMP accesories that are connected - for instance, the advanced features of the display RSM such as the backlight and volume controls will not function properly. It seems like the radio will attempt to do an XCMP handshake at boot-time, and then fails back to SB9600 if it cannot negotiate with an XCMP device. However, the radio does not seem to completely reset and re-initialize the accessory connection when it fails back, so the RSM is not in a properly initialized state.

Since this setting can actually prevent accessories from functioning properly, it seems that Motorola should amend the CPS help files to be a bit more descriptive about what this setting is intended to do. I think I'll actually do some testing to see if this setting would prevent the emergency button on the RSM from functioning properly. If you don't notice the error during boot, you'd never know anything is wrong until you hit the orange button and nothing happens.

KG4FOY
Posts: 156
Joined: Wed Feb 21, 2007 9:33 am

Re: APX7000 error code 15/10 what is it?

Postby KG4FOY » Tue May 15, 2012 8:27 pm

I can see that posing a problem..


Return to “General Motorola Solutions & Legacy Radio Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests